Back to overview
Resolved

Platform outage (already recovered)

Jul 2, 2026 at 8:55am UTC
Affected services
Judoscale web app
Adapter API (metrics ingest)
Heroku autoscaling
Render autoscaling
Amazon ECS autoscaling
Fly.io autoscaling
Railway autoscaling

Resolved
Jul 2, 2026 at 9:12am UTC

Web and ingest traffic have normalized.

Updated
Jul 2, 2026 at 9:02am UTC

It seemed to recover in ~20 min, but during that time both web and ingest were hitting "502 Bad Gateway" or Cloudflare errors trying to reach the app.

We continue to monotir the situation.

Created
Jul 2, 2026 at 8:55am UTC

Around 8:40AM UTC we were alerted by an issue reaching both our staging and production apps, and we identified that our current platform (Railway) is having a major outage.

We apologize for the disruption, and are monitoring the situation with our platform.